Menu principale

DSL-2780 TalkTalk (thread temporaneo)

Aperto da bovirus, 27 Giugno 2012, 16:11:13




Ultimo firmware DSL-2780 TalkTalk.

Fonte TalkTalk Labs
DLink DSL2780 v2.03t Firmware
Last updated on 2013-06-05 16:29:42

TalkTalk Labs are pleased to announce [...] a new version of the D-Link DSL-2780 Router firmware. The [...] firmware delivers the below improvements:

• Auto Wireless Channel Selection by default
• Multiple TR-069 (Remote Management) improvements to help TalkTalk proactively identify faults in the home
• Fix for intermittent iChat issue
• Fix for intermittent iOS wireless issue
• Fix for wireless issues with some Android phones (HTC Desire, Sony Xperia S, Nexus 4)
• Change to show the Summary page first in the router UI


I have this modem from UK's TalkTalk ISP and now I'm trying to use it with a different broadband provider. My username with my broadband provider is my phone number. When I try that I got a message error saying that the user name must be under the form of "username@domain". In other word it must be something like "" or "".
Is there a way to use a username that doesn't look like an email address?

I have already tried TalkTalk's firmware v1.12, v1.13, v2.02t and v2.03t.
Also, I tried to install Conceptronic C300BRS4A firmware. But that didn't work. After rebooting the modem, it display a white page asking me to re-install the firmware.
Also, I tried to install the firmware for the D-Link "DSL-2740R" modem but it didn't want to install. I also tried the firmware for the D-Link "DSL-2740B" and that didn't work either.


You have to use only TalkTalk firmwares or you risk to brick your device.

Try if it works:



Citazione di: Pondera il 01 Luglio 2014, 14:57:02You have to use only TalkTalk firmwares or you risk to brick your device.

Try if it works:


Hi Pondera
Thanks for your reply.

My ISP uses only "YourPhoneNumber" without  "@YourIspDomain.YourCountryDomain" as the  username, like:

username: 023872934765

Is there a way to write the username without "@YourIspDomain.YourCountryDomain"?


Why don't you try if the workaround I suggested works?


Citazione di: Pondera il 03 Luglio 2014, 12:06:05Why don't you try if the workaround I suggested works?

Hi Pondera,

Sorry for the late reply. I have tried your suggestion but it doesn't work. I can't connect to my ISP is I write my username as:

Username: PhoneNumber@IspDomain.CountryDomain.

The only format accepted by my ISP is (Username = PhoneNumber) like:

UserName: 0123456789

I have bricked the modem while trying to install OpenWRT, but I recovered by re-installing the TalkTalk one.

As I said before I have also tried to install Conceptronic firmware, the DSL-2740B and DSL-2740R firmware. Is there any other firmware I can try? I don't mind damaging the modem since right now I can't use it anyways.

Or is there any other solution you can think of that forces TalkTalk firmware to access a UserName without @IspDomain.CountryName (force it to accept numbers only).



Citazione di: Pondera il 13 Luglio 2014, 16:44:06Who is your ISP?
Hi Pondera,

I'm sure you haven't heard of my ISP since it's local and outside the EU. It is called GAT.

So, is there a way to force this modem to accept a simple phone number without "@ISPDomainName.CountryDomain" as a username or not?

If these is no solution for my request I'll just through away this modem and carry on using the old one.  

Thanks and best,


780 / 5.000
Risultati della traduzione
I really wish a good day to everyone who reads this mail
I understand that this is an old thread but I still want to try.
I own an old DSL-2780 which responds to the SSID as TALKTALK-7559F0. I guess it's a TALK TALK router (it was Infostrada) but I don't have any labels on the back.
The management software tells me
Hardware version: A2
ADSL Firmware Version: v1.4
Firmware Version: v1.11_04212010
I would like to use it as a WIFI extender but the router lose too mutch packets.
I searched for a new firmware on the web  (I read that there is a v2.03t of the Firmware) but the links are now all expired.
Can someone share me a link with a more updated version of the firmware than the one I have (which is of 2010)
Thank you for a kind reply


Hi and welcome to our D-Link Unofficial Italian Forum. :D

Here in this thread you can find our firmwares backups attached to download:

D-Link DSL-2780 - v1.13t.rar + D-Link DSL-2780 - v2.02t.rar
D-Link DSL-2780 - v2.03t.rar

Citazione di: ANTO955 il 09 Febbraio 2022, 08:38:16I would like to use it as a WIFI extender but the router lose too mutch packets.

To use DSL-2780 TT as WiFi extender you can only link it via LAN cable to your main router. If you have packets loss maybe it's better to re-control LAN cable integrity and/or try to change LAN port.


Thank-you for the very fast answer.
Unfortunally none of the links works ( error 404....) :(
I checked them, that I found also in other sites, before to write.

I am using a power-line extender and connecting directly to it, there is no "loss". More exaclty is not really a packet loss. It happens that pinging contionuosly the default gateway sometimes the delay reach 1000 ms and the voice over IP become unintelligible


Typically up to 100ms latency is not generally going to cause a noticeable issue in VoIP quality. But getting over 100ms will most certainly be noticed.[*]
Most likely the cause of your issue is the so-called bufferbloat:

Bufferbloat is the undesirable latency that comes from a router or other network equipment buffering too much data.
Modern xDSL modems has got SQM (Smart Queue Management) option to avoid it. Or you can try setting your modem to bridge-mode adding it to a new router or to a router updated with an alternative open-source firmware such as OpenWrt & DD-WRT:

Here below they seem to solve bufferbloat issue simply using QoS function:

and also here even if not on a low cost old modem such as DSL-2780:


Licenza Creative Commons
Il contenuto dei messaggi del forum è distribuito con
Licenza Creative Commons Attribuzione Non commerciale 4.0
Tutti i marchi registrati citati appartengono ai legittimi proprietari
Consensi Privacy